1
0
Fork 0
mirror of https://github.com/SinTan1729/aur-packages.git synced 2025-04-11 06:06:05 -05:00
aur-packages/movie-rename-bin/PKGBUILD

28 lines
1.1 KiB
Bash

# Maintainer: Sintan Santorum <c1scu0hh at anonaddy dot me>
pkgname="movie-rename-bin"
_pkgname="movie-rename"
pkgver=2.3.2
pkgrel=1
pkgdesc="A simple tool to rename movies, written in Rust."
arch=('x86_64')
url="https://github.com/SinTan1729/$_pkgname"
license=('GPL3')
provides=('movie-rename')
source=("$_pkgname-$pkgver.tar.gz::$url/releases/download/$pkgver/$_pkgname.tar.gz")
b2sums=('dff31a4ea45fdca5d56b8043d2184951cf8c9b121a7466e4988d4e02790d6d4f784727eec1ca9fc9bc75ae41a7b9b2cda1a4b1db6fb4390aa93e18ba84d39954')
package() {
# binary
install -Dm755 ./$_pkgname "$pkgdir/usr/bin/$_pkgname"
# manpage
install -Dm644 ./$_pkgname.1 "$pkgdir/usr/share/man/man1/$_pkgname.1"
# completions
if $(command -v fish &>/dev/null); then
install -Dm644 ./$_pkgname.fish "${pkgdir}/usr/share/fish/completions/$_pkgname.fish"
fi
if $(command -v bash &>/dev/null); then
install -Dm644 ./$_pkgname.bash "${pkgdir}/usr/share/bash-completion/completions/$_pkgname"
fi
if $(command -v zsh &>/dev/null); then
install -Dm644 ./$_pkgname.zsh "${pkgdir}/usr/share/zsh/site-functions/_$_pkgname"
fi
}